Пишет Disconnect в Веб интерфейсе


#1

Здравствуйте. Включил и настроил WB6 на работе. Все заработало без нареканий. После принес домой подключил к локальной сети. Нашел ip адрес, подключился к веб интерфейсу, при подключении спросил логин и пароль настроенный ранее. Но в веб интерфейсе справа в верху пишет Disconnect. При этом во вкладках не чего не отображается. В чем может быть причина?
Дома ip адреса другие, не такие как на работе.


#2

После этого приносил на работу и там все работает, приношу обратно домой и снова пишет Disconnect


#3

а по ssh заходит?


#4

в консоли браузера ошибки/лог посмотрите


#5

по ssh заходит без проблем


#6

Браузер/фаерволл? Компьютеры, как я понимаю, разные? Что в отладочной консоли браузера отображается?


#7

скрпипты на странице обращаются к контроллеру по своим портам, ваш файрвол может не пропускать эти исходящие коннекты. Отключите его на время и проверьте.


#8

Там один порт, 18883, websockets, с которым бывает проблема. Смотрите отладочную консоль. Там ошибки типа “не могу подключиться” или “Security error: this operation is insecure”. Первое – проблема фаервола. Второе – браузера. Какой вы используете?


#9

Понял. Вечером проверю, отпишусь.


#10

Да вы были правы насчет порта 18883.
WebSocket connection to ‘ws://192.168.1.96:18883/mqtt’ failed: Error in connection establishment: net::ERR_CONNECTION_REFUSED
Браузер Chrome


#11

А что за система? Антивирусы-фаерволлы? Понятно, что может блокировать? Можете попробовать Firefox – какие в нем ошибки?


#12

windows7. esential. попробовал отключить брандмауэр и антивирус. Пробовал открывать в яндекс браузере не помогло.


#13

тогда вопрос, а что изначально вы настраивали?
я вот кажется вообще ничего не настраивал и все вроде работает


#14

А подключиться telnet на порт 18883 можете, соединение устанавливается? Проверьте с телефона зайти на web-интерфейс, чтобы удостоверится, что все хорошо/плохо с сетью :slight_smile: