Плюс для WB-MRGB[-D]


#1

Если (логическая часть) WB-MRGB или WB-MRGB-D запитана через “V+”, можно ли вообще не подключать ничего к клеммам “+”? То есть просто вести “+” на ленту, а к диммеру только минус питания и минус ленты? Или нужно обязательно и плюс питания ленты подвести?


#2

#3

Можно.


#4

Аналогичный вопрос про WB-MD2: обязательно ли к диммеру подводить N? или достаточно фазу и OUT1/OUT2 на нагрузку, с которой уже пойдёт в N?


#5

В WB-MD2 нужна и нейтраль и фаза.


#6

При маленькой нагрузке всё работало как надо.
Но когда подключил две ленты по 62W (24V) начала странно моргать одна из лент, причём лишь когда довожу её до 75% яркости и только если опрашиваю диммер. Моргает 1-2 герца плавно тухнет/загорается. (с одной большой и одной маленькой ленточкой всё было ок).

То есть:
PSU 480W 24V подключён минусом к минусу WB-MRGB (питание лент), плюсом к лентам.
Цветные минусы WB-MRGB подключены к минусам лент.
PSU 100W 24V подключён к питанию WB-MRGB, минус также подключён к gnd 485 (usb-485)
И при этом непрерывно вычитываю регистры (задержка 35мс между транзакциями).
Диод на WB-MRGB моргает с заметными паузами, а не ритмично, как при нормальной работе.

Когда подключил плюс большого блока питания к диммеру - всё заработало как надо.

Поясните пожалуйста, в чём может быть дело. Плюс всё-таки нужно подключать или дело в чём-то сосем другом и я что-то делаю не так?


#7

Что-то больше похоже на помехи по RS-485. Может кабель не витой парой, может по земле токи куда-то не туда и не так текут - я бы на это обратил внимание.


#8

кабель - витая пара и совсем коротенький, до 1,5м.
помех нету при меньшей нагрузке и нету при подключённом плюсе.
вы точно уверены, что плюс не нужен для нормальной работы при правильном подключении?
просто при подключении плюса всё работает без видимых проблем и это настораживает.
не знаю как искать иную причину…


#9

мужик, значит нужен :slight_smile:

вообще с самого начала ветки сомневался, что можно плюсы напрямую заводить. Хотя в документации сказано, что их плюсы внутри модуля коротко соединены. Но судя по всему не совсем коротко :slight_smile:


#10

Так плюсы в модуле на стороне лент используются только для защиты.

Я припоминаю похожий случай, когда безымянный китайский блок питания для светодиодных лент испускал какие-то помехи по питанию и клал RS-485. Возможно тут тоже самое: на это указывает нерегулярно мигающий светодиод и медленное мерцание ленты (читай - ложное срабатывание неиспользуемого дискретного входа для кнопок).

У вас точно соединены все земли: usb-rs485, WB-MRGB-W, двух блоков питания хорошим проводом в одной точке?


#11

Да, забыл сказать, ленты питаю этим: Mean Well SDR-480P-24 (пока одиночным, без current sharing)
А диммер этим: Mean Well MDR-100-24

Кстати управление кнопками я отключил.

Подскажите заодно пожалуйста, что именно нужно соединить? Минусы вообще всех блоков питания в схеме? И их земли (frame ground)? Но минусы с FG ведь не нужно? Или тоже соединить? Соединять даже если БП от разных фаз и бесперебойника?
Соединил всё что только можно - не помогло.

Как оказалось, моргает даже без подключения rs485 вообще. Но только если сначала включить БП лент.

Если сначала включить БП диммера, а потом лент - не моргает. Но если потом выключить (записать в регистры каналов 0) - гаснет не плавно, а резко и начинает моргать. Или если повышать яркость, как я писал выше - примерно с 75% на второй ленте начинает моргать.

Заменил оба блока питания и диммер - тот же результат, моргает.


#12

А в чем проблема питать и ленты и диммер от одного блока питания?


#13

Диммер питаться будет от заупсованного.
Но это неважно. Вопрос в том, почему именно моргает, если Вы говорите, что не должно, значит что-то неправильно у меня. Непоняно что.


#14

Тогда можно оба блока питания подключить.
Когда диммируются ленты, возникают небольшие всплески напряжения (из-за индуктивности проводов). Эти всплески уходят обратно через “+” в блок питания, если он подключен, или гасятся на защитном диоде TVS, если не подключен. Возможно во втором случае генерируются бОльшие помехи. У меня такие предположения. Впишу в документацию рекомендацию подключать “+”.