Обновление прошивки до актуальной версии


#1

У меня после прошивки у wb-mqtt-serial версия 1.26.5
если обновиться целиком, то предлагается удалить wb-homeui.
Стоит соглашаться или нет?

root@wirenboard-ARAXKJYF:~# apt-get update && apt-get install wb-mqtt-serial
Get:1 http://mirror.yandex.ru wheezy Release.gpg [2373 B]
Get:2 http://mirror.yandex.ru wheezy-updates Release.gpg [1601 B]
Get:3 http://security.debian.org wheezy/updates Release.gpg [1601 B]
Get:4 http://mirror.yandex.ru wheezy Release [191 kB]
Get:5 http://security.debian.org wheezy/updates Release [39.0 kB]
Get:6 http://http.debian.net wheezy-backports Release.gpg [1601 B]
Get:7 http://mirror.yandex.ru wheezy-updates Release [155 kB]
Get:8 http://http.debian.net wheezy-backports Release [168 kB]
Get:9 http://releases.contactless.ru wheezy Release.gpg [473 B]
Get:10 http://releases.contactless.ru wheezy Release [5202 B]
Get:11 http://mirror.yandex.ru wheezy/main armel Packages [5710 kB]
Get:12 http://security.debian.org wheezy/updates/main armel Packages [583 kB]
Get:13 http://security.debian.org wheezy/updates/main Translation-en [321 kB]
Get:14 http://releases.contactless.ru wheezy/main armel Packages [74.0 kB]
Get:15 http://http.debian.net wheezy-backports/main armel Packages [581 kB]
Ign http://releases.contactless.ru wheezy/main Translation-en
Get:16 http://http.debian.net wheezy-backports/main Translation-en [380 kB]
Get:17 http://mirror.yandex.ru wheezy/main Translation-en [3846 kB]
Get:18 http://mirror.yandex.ru wheezy-updates/main armel Packages [6247 B]
Get:19 http://mirror.yandex.ru wheezy-updates/main Translation-en [4879 B]
Fetched 12.1 MB in 2min 57s (68.1 kB/s)
Reading package lists… Done
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following packages were automatically installed and are no longer required:
liblog4cpp5 wb-mqtt-db
Use ‘apt-get autoremove’ to remove them.
The following extra packages will be installed:
libwbmqtt0 wb-homa-adc wb-hwconf-manager
The following packages will be REMOVED:
wb-mqtt-homeui
The following packages will be upgraded:
libwbmqtt0 wb-homa-adc wb-hwconf-manager wb-mqtt-serial
4 upgraded, 0 newly installed, 1 to remove and 42 not upgraded.
Need to get 263 kB of archives.
After this operation, 46.8 MB disk space will be freed.
Do you want to continue [Y/n]?


#2

Попробуйте явно указать apt-у, что пакет удалять нельзя:

apt-get install wb-mqtt-serial wb-mqtt-homeui

#3

прошу создать отдельную тему под отдельный вопрос


#4

Перезагрузка потребуется? и как проверить какие сервисы запущены вообще?


#5

нет

ps aux  | grep wb-

или

service wb-mqtt-serial status

#6

Все обновилось. Спасибо за помощь


#7

Это похоже на свежий баг с зависимостями в репозитории, поставил в очередь на исправление.


#8

Здравствуйте! проблема!!! что делать обновился по выше изложенной здесь инструкции и после этого в web интерфейсе Error loading the file: Invalid config file что делать? помогите!