Не верно работают модули


#1

Добрый день

Собираю конфигурацию из:

WB6 + R1G-16 + R1G-16 + R1G-16 + AI-DV-12 + DI-HVD-16

Через Веб интерфейс добавил устройства в Hardware Modules Configuration.

Далее проблемы:

  1. Релейные модули на 16 каналов, когда в веб интерфейсе замыкаешь каналы, какая то часть реле срабатывает, а какая то нет на всех трех модулях. После перезагрузки контроллера последовательность рабочих каналов меняется.

  2. Модуль DI-HVD-16. При подачи питания согласно схеме на входа, в веб интерфейсе нечего не меняется.

  3. Модуль AI-DV-12/4-20MA. Отсутствует в Devices и Settings, в ADC Driver Configuration присутствуют все 12 каналов. В Hardware Modules Configuration нет возможности выбрать 4-20мА, только 0-20мА, 0-2,5В, ±50В.

Какие варианты решения данных проблем?


#2

По 3-му пункту пробовал следующее:

~# apt-get install wb-hwconf-manager linux-image-wb2 wb-homa-adc
Reading package lists… Error!
E: Write error - write (28: No space left on device)
E: IO Error saving source cache
E: The package lists or status file could not be parsed or opened.


#3

У вас закончилось место на устройстве. Пожалуйста, помогите нам провести диагностику, почему это случилось. Для этого вам нужно найти файлы, которые заняли много места по инструкции: https://www.tecmint.com/find-top-large-directories-and-files-sizes-in-linux/


#4

du -a / home | sort -n -r | head -n 5
1719580 /
1147144 /var
1116316 /var/log
1115940 /var/log/messages
351944 /usr

Сам по себе файл messages занимает больше гига, это через winscp тоже видно


#5

Спасибо.
Пожалуйста, скопируйте файл /var/log/messages к себе на компьютер, заархивируйте и пришлите нам на info@contactless.ru каким-нибудь способом (например, выложив на файлохранилище).


#6

Отправил, но мне на компе не чем не удалось его открыть из за размера


#7

К сожалению, не получил от вас файл. Написал вам письмо на почту, чтобы договориться, как передать файл.


#8

Ваша почта не пропускает письма с вложениями, отправил ссылку на яндекс диск


#9

Файл получили, изучаем.
Сейчас сделайте, пожалуйста, следующее:

  1. Удалите /var/log/messages.
  2. Перезагрузите контроллер.
  3. Проверьте, всё ли работает корректно. Большая часть проблем должна разрешиться; про все проблемы пишите сюда.
  4. Примерно через час после этого отправьте мне на почту новый /var/log/messages.

#10

Файл отправил.

На данный момент не один модуль вообще не работает и не работают страницы Network interface, Hardware module, digital outputs, везде ругается на неверный файл конфигурации. Как поправить файлы?


#11

Добрый день!

Посмотрели.
Пожалуйста, выполните:

apt update
apt -s upgrade

и пришлите вывод сюда.


#12

root@wirenboard-AJ5LRJPE:~# apt update
Ign:1 http://mirror.yandex.ru/debian stretch InRelease
Get:2 http://security.debian.org stretch/updates InRelease [94.3 kB]
Get:3 http://mirror.yandex.ru/debian stretch-updates InRelease [91.0 kB]
Get:5 http://releases.contactless.ru/stable/stretch stretch InRelease [10.6 kB]
Hit:6 http://mirror.yandex.ru/debian stretch Release
Get:4 http://cdn-fastly.deb.debian.org/debian stretch-backports InRelease [91.8 kB]
Get:7 http://security.debian.org stretch/updates/main armhf Packages [422 kB]
Get:8 http://releases.contactless.ru/stable/stretch stretch/main armhf Packages [71.9 kB]
Get:9 http://security.debian.org stretch/updates/main Translation-en [189 kB]
Get:10 http://releases.contactless.ru/stable/stretch stretch/main all Packages [26.9 kB]
Get:12 http://cdn-fastly.deb.debian.org/debian stretch-backports/main armhf Packages.diff/Index [27.8 kB]
Get:13 http://cdn-fastly.deb.debian.org/debian stretch-backports/main Translation-en.diff/Index [27.8 kB]
Get:14 http://cdn-fastly.deb.debian.org/debian stretch-backports/main armhf Packages 2018-09-13-0808.24.pdiff [525 B]
Get:15 http://cdn-fastly.deb.debian.org/debian stretch-backports/main armhf Packages 2018-09-14-0206.36.pdiff [288 B]
Get:16 http://cdn-fastly.deb.debian.org/debian stretch-backports/main armhf Packages 2018-09-14-0810.49.pdiff [658 B]
Get:17 http://cdn-fastly.deb.debian.org/debian stretch-backports/main armhf Packages 2018-09-14-2008.28.pdiff [201 B]
Get:18 http://cdn-fastly.deb.debian.org/debian stretch-backports/main armhf Packages 2018-09-15-0807.02.pdiff [556 B]
Get:19 http://cdn-fastly.deb.debian.org/debian stretch-backports/main armhf Packages 2018-09-16-1412.52.pdiff [7826 B]
Get:20 http://cdn-fastly.deb.debian.org/debian stretch-backports/main armhf Packages 2018-09-16-2018.37.pdiff [3165 B]
Get:21 http://cdn-fastly.deb.debian.org/debian stretch-backports/main armhf Packages 2018-09-17-0206.40.pdiff [607 B]
Get:22 http://cdn-fastly.deb.debian.org/debian stretch-backports/main armhf Packages 2018-09-17-0814.05.pdiff [4180 B]
Get:23 http://cdn-fastly.deb.debian.org/debian stretch-backports/main armhf Packages 2018-09-17-1409.40.pdiff [315 B]
Get:24 http://cdn-fastly.deb.debian.org/debian stretch-backports/main armhf Packages 2018-09-17-2011.05.pdiff [521 B]
Get:25 http://cdn-fastly.deb.debian.org/debian stretch-backports/main Translation-en 2018-09-16-1412.52.pdiff [8967 B]
Get:26 http://cdn-fastly.deb.debian.org/debian stretch-backports/main Translation-en 2018-09-16-2018.37.pdiff [1706 B]
Get:27 http://cdn-fastly.deb.debian.org/debian stretch-backports/main Translation-en 2018-09-17-0206.40.pdiff [1489 B]
Get:24 http://cdn-fastly.deb.debian.org/debian stretch-backports/main armhf Packages 2018-09-17-2011.05.pdiff [521 B]
Get:28 http://cdn-fastly.deb.debian.org/debian stretch-backports/main Translation-en 2018-09-17-0814.05.pdiff [1350 B]
Get:29 http://cdn-fastly.deb.debian.org/debian stretch-backports/main Translation-en 2018-09-17-2011.05.pdiff [572 B]
Get:29 http://cdn-fastly.deb.debian.org/debian stretch-backports/main Translation-en 2018-09-17-2011.05.pdiff [572 B]
Fetched 1087 kB in 11s (95.4 kB/s)
Reading package lists… Done
Building dependency tree
Reading state information… Done
36 packages can be upgraded. Run ‘apt list --upgradable’ to see them.
root@wirenboard-AJ5LRJPE:~# ^C
root@wirenboard-AJ5LRJPE:~# apt -s upgrade
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
The following packages will be upgraded:
base-files ca-certificates curl device-tree-compiler dpkg file
firmware-realtek libcurl3 libcurl3-gnutls libipc-run-perl libldap-2.4-2
libldap-common libmagic-mgc libmagic1 libpam-systemd libsystemd0 libudev1
linux-firmware-image-4.9.22-wb6 linux-image-4.9.22-wb6 linux-image-wb6
linux-libc-dev openssh-client openssh-server openssh-sftp-server
python-wb-io shared-mime-info systemd systemd-sysv udev wb-homa-gpio
wb-hwconf-manager wb-mqtt-dac wb-mqtt-serial wb-rules-system wb-test-suite
wb-utils
36 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Inst base-files [9.9+deb9u4] (9.9+deb9u5 Debian:9.5/stable [armhf])
Conf base-files (9.9+deb9u5 Debian:9.5/stable [armhf])
Inst dpkg [1.18.24] (1.18.25 Debian:9.5/stable [armhf])
Conf dpkg (1.18.25 Debian:9.5/stable [armhf])
Inst systemd-sysv [232-25+deb9u3] (232-25+deb9u4 Debian:9.5/stable [armhf])
Inst libpam-systemd [232-25+deb9u3] (232-25+deb9u4 Debian:9.5/stable [armhf]) []
Inst libsystemd0 [232-25+deb9u3] (232-25+deb9u4 Debian:9.5/stable [armhf]) [systemd:armhf ]
Conf libsystemd0 (232-25+deb9u4 Debian:9.5/stable [armhf]) [systemd:armhf ]
Inst systemd [232-25+deb9u3] (232-25+deb9u4 Debian:9.5/stable [armhf])
Inst udev [232-25+deb9u3] (232-25+deb9u4 Debian:9.5/stable [armhf]) []
Inst libudev1 [232-25+deb9u3] (232-25+deb9u4 Debian:9.5/stable [armhf])
Conf libudev1 (232-25+deb9u4 Debian:9.5/stable [armhf])
Inst file [1:5.30-1+deb9u1] (1:5.30-1+deb9u2 Debian:9.5/stable [armhf]) []
Inst libmagic1 [1:5.30-1+deb9u1] (1:5.30-1+deb9u2 Debian:9.5/stable [armhf]) []
Inst libmagic-mgc [1:5.30-1+deb9u1] (1:5.30-1+deb9u2 Debian:9.5/stable [armhf])
Inst libldap-common [2.4.44+dfsg-5+deb9u1] (2.4.44+dfsg-5+deb9u2 Debian:9.5/stable [all])
Inst libldap-2.4-2 [2.4.44+dfsg-5+deb9u1] (2.4.44+dfsg-5+deb9u2 Debian:9.5/stable [armhf])
Inst openssh-sftp-server [1:7.4p1-10+deb9u3] (1:7.4p1-10+deb9u4 Debian-Security:9/stable [armhf]) []
Inst openssh-server [1:7.4p1-10+deb9u3] (1:7.4p1-10+deb9u4 Debian-Security:9/stable [armhf]) []
Inst openssh-client [1:7.4p1-10+deb9u3] (1:7.4p1-10+deb9u4 Debian-Security:9/stable [armhf])
Inst ca-certificates [20161130+nmu1] (20161130+nmu1+deb9u1 Debian:9.5/stable [all])
Inst curl [7.52.1-5+deb9u6] (7.52.1-5+deb9u7 Debian-Security:9/stable [armhf]) []
Inst libcurl3 [7.52.1-5+deb9u6] (7.52.1-5+deb9u7 Debian-Security:9/stable [armhf])
Inst device-tree-compiler [1.4.1+wb20180629091028] (1.4.1+wb20180808183130 stable/stretch stretch:stretch [armhf])
Inst firmware-realtek [0.43] (20170823-1~bpo9+1 stable/stretch stretch:stretch [all])
Inst libcurl3-gnutls [7.52.1-5+deb9u6] (7.52.1-5+deb9u7 Debian-Security:9/stable [armhf])
Inst libipc-run-perl [0.94-1] (0.94-1+deb9u1 Debian:9.5/stable [all])
Inst linux-firmware-image-4.9.22-wb6 [4.9+wb20180629091028] (4.9+wb20180901162751 stable/stretch stretch:stretch [all])
Inst linux-image-4.9.22-wb6 [4.9+wb20180629091028] (4.9+wb20180901162751 stable/stretch stretch:stretch [armhf])
Inst linux-image-wb6 [4.9+wb20180629091028] (4.9+wb20180901162751 stable/stretch stretch:stretch [armhf])
Inst linux-libc-dev [4.9.88-1+deb9u1] (4.9.110-3+deb9u4 Debian-Security:9/stable [armhf])
Inst python-wb-io [1.2.2] (1.2.3 stable/stretch stretch:stretch [armhf])
Inst shared-mime-info [1.8-1] (1.8-1+deb9u1 Debian:9.5/stable [armhf])
Inst wb-homa-gpio [1.19] (1.19.1 stable/stretch stretch:stretch [armhf])
Inst wb-mqtt-dac [1.1] (1.1.1 stable/stretch stretch:stretch [all])
Inst wb-mqtt-serial [1.41.3] (1.44 stable/stretch stretch:stretch [armhf])
Inst wb-utils [1.75.5] (1.75.6 stable/stretch stretch:stretch [all])
Inst wb-rules-system [1.4.2] (1.6 stable/stretch stretch:stretch [all])
Inst wb-hwconf-manager [1.22] (1.24.1 stable/stretch stretch:stretch [all])
Inst wb-test-suite [1.12] (1.13.1 stable/stretch stretch:stretch [all])
Conf systemd-sysv (232-25+deb9u4 Debian:9.5/stable [armhf])
Conf libpam-systemd (232-25+deb9u4 Debian:9.5/stable [armhf])
Conf systemd (232-25+deb9u4 Debian:9.5/stable [armhf])
Conf udev (232-25+deb9u4 Debian:9.5/stable [armhf])
Conf file (1:5.30-1+deb9u2 Debian:9.5/stable [armhf])
Conf libmagic1 (1:5.30-1+deb9u2 Debian:9.5/stable [armhf])
Conf libmagic-mgc (1:5.30-1+deb9u2 Debian:9.5/stable [armhf])
Conf libldap-common (2.4.44+dfsg-5+deb9u2 Debian:9.5/stable [all])
Conf libldap-2.4-2 (2.4.44+dfsg-5+deb9u2 Debian:9.5/stable [armhf])
Conf openssh-sftp-server (1:7.4p1-10+deb9u4 Debian-Security:9/stable [armhf])
Conf openssh-server (1:7.4p1-10+deb9u4 Debian-Security:9/stable [armhf])
Conf openssh-client (1:7.4p1-10+deb9u4 Debian-Security:9/stable [armhf])
Conf ca-certificates (20161130+nmu1+deb9u1 Debian:9.5/stable [all])
Conf curl (7.52.1-5+deb9u7 Debian-Security:9/stable [armhf])
Conf libcurl3 (7.52.1-5+deb9u7 Debian-Security:9/stable [armhf])
Conf device-tree-compiler (1.4.1+wb20180808183130 stable/stretch stretch:stretch [armhf])
Conf firmware-realtek (20170823-1~bpo9+1 stable/stretch stretch:stretch [all])
Conf libcurl3-gnutls (7.52.1-5+deb9u7 Debian-Security:9/stable [armhf])
Conf libipc-run-perl (0.94-1+deb9u1 Debian:9.5/stable [all])
Conf linux-firmware-image-4.9.22-wb6 (4.9+wb20180901162751 stable/stretch stretch:stretch [all])
Conf linux-image-4.9.22-wb6 (4.9+wb20180901162751 stable/stretch stretch:stretch [armhf])
Conf linux-image-wb6 (4.9+wb20180901162751 stable/stretch stretch:stretch [armhf])
Conf linux-libc-dev (4.9.110-3+deb9u4 Debian-Security:9/stable [armhf])
Conf python-wb-io (1.2.3 stable/stretch stretch:stretch [armhf])
Conf shared-mime-info (1.8-1+deb9u1 Debian:9.5/stable [armhf])
Conf wb-homa-gpio (1.19.1 stable/stretch stretch:stretch [armhf])
Conf wb-mqtt-dac (1.1.1 stable/stretch stretch:stretch [all])
Conf wb-mqtt-serial (1.44 stable/stretch stretch:stretch [armhf])
Conf wb-utils (1.75.6 stable/stretch stretch:stretch [all])
Conf wb-rules-system (1.6 stable/stretch stretch:stretch [all])
Conf wb-hwconf-manager (1.24.1 stable/stretch stretch:stretch [all])
Conf wb-test-suite (1.13.1 stable/stretch stretch:stretch [all])


#13

нечего не поменялось


#14

Добрый день!

Это была команда для диагностики, ничего не должно было поменяться.
Сохраните, пожалуйста, с контроллера все важные данные, затем обновите все пакеты:
apt upgrade
Если после этого проблема не исчезнет, то вариант один - сброс к заводской прошивке.